TASK 69-233-03

Prepared for
Goddard Space Flight Center

Prepared by:
L. McDonald

Printed on Jul 22, 1998
User's Guide on January 1993


This document provides information on how to use the IDL version of SKYMAP. Section 1 contains a general description of the program. Section 2 lists the steps to execute the program. The program I/O interface is described in section 3.


  1. General Description
    1. Program Purpose
    2. Program Description
    3. Applicable Documents
  2. Running the Program
    1. Hardware Requirements
    2. Preliminary Requirements
    3. Execution
  3. I/O Interface
    1. Inputs
    2. Image Display
    3. Analysis Options
    4. Outputs

1  General Description

1.1  Program Purpose

The IDL SKYMAP program reads and displays images stored in files that contain a valid FITS image and header or ASCII files generated from the EGRET scientific analysis program LIKE. Additionally, the program features a number of interactive data analysis tools that will allow the user to locate the maximum bin, display the value and coordinates of a bin, smooth the image, logarithmically scale the image, draw image contours, project histograms reflecting bin value totals for each axis, print the image, rescale the pixel colors and zoom in on a subimage.

1.2  Program Description

The SKYMAP program runs from within IDL. When SKYMAP is run a window will appear containing an area displaying instructions and information, an area where all files in the directory set by the environment variable FITS_DIR are listed, an image display area and data analysis tools menu. The user will select a file from the File Listing area or select one of the suboptions under the Alt File menu option to select a file that is not listed. The image stored in the selected file will be displayed and the program then waits for an analysis option, another file or the EXIT menu option to be selected. At input time, the user will only need to know what file is to be displayed and its location on the system.

1.3  Applicable Documents

Additional information related to the SKYMAP program may be found in the following documents.

  1. MAPGEN Program Definition
  2. Implementation of the Flexible Image Transport System NOST 100-0.3b
  3. EGRET Telemetry and Data Formats, # 82-3-5

2  Running the Program

2.1  Hardware Requirements

The IDL version of SKYMAP will run in the windowing environment on Sun4 systems and SPARCstations onto which IDL software has been installed.

2.2  Preliminary Requirements

Prior to running the program, a number of environment variables should be properly set. The default values of these variables are normally set by adding an entry for each in the user's .cshrc file. The specific environment variable declarations that should be included in the user's .cshrc file are:

   IDL_PATH ........ directory path specifying the locations of all IDL

   FITS_DIR ........ directory location of files containing images that are
                      to be displayed

   MISC_DIR ........ directory location of files containing the data used
                      to display sources and the color tables.

To manually set an environment variable, use the setenv command e.g.

setenv FITS_DIR ~userid/fits

     setenv IDL_PATH  
/lib/idl.general: /usr1/lib/idl.local
The program will use these variables to access all necessary IDL routines and data files.

2.3  Execution

The SKYMAP program may normally be run from any directory in a windowing environment. To run SKYMAP, the user can type skymap at the Unix prompt. This command runs a shell script that invokes IDL and runs the SKYMAP routine. Optionally, the user can run SKYMAP from within IDL by typing idl at the Unix prompt and then skymap at the IDL prompt.

3  I/O interface

All I/O takes place from the one SKYMAP window seen in Figure 1 as it first appears. The top left area, hereafter called the Instructions/Information area, will display instructions and information, providing a history of the user's selections. Underneath this area is the File Listing area where, initially, files located in the directory specified by the environment variable FITS_DIR are displayed. The EXIT button is below the File Listing area. On the right side of the window is the Image Display area and along the bottom is the Data Analysis Tools menu. Files and menu items are selected by moving the cursor to the file name or menu button and clicking once. Arrows displayed next to the button label of or an extra "box" around the Data Analysis Tools menu item indicate that there are suboptions for this menu item. These suboptions will appear when you click once on the menu button with the left mouse button. The user then selects one of the suboptions, again by clicking on it once. If user input is required after selecting a menu item, a separate window will be displayed to accept the input. Whenever possible, the program automatically moves the focus to this input window.

3.1  Inputs

Skymap window

Figure 1: Skymap window larger

Skymap Window (figure 1)

3.4  Outputs

When EXIT is selected, a file named skymap_session.dat is created in the user's HOME directory. This file contains all current local and system variables and will be read in the user's next SKYMAP session if the Restore Session option is selected. The only other output from SKYMAP occurs if the Hardcopy option has been selected and is in the form of a PostScript file. This PostScript file is named and is located in the user's HOME directory unless Print Setup has been used to change the name and location of this file. If the user is running SKYMAP from a local machine the PostScript file may be sent to a local printer.

File translated from TEX by TTH, version 1.56.