Blink Images/Graphs

Within POW, multiple images can be examined for differences by the common technique of overlaying them and blinking them in rapid succession. Pow provides two methods for doing this.

Blink Images...

Multiple images can be placed within a single POW graph. This can be achieved by merging the contents of several graphs into a single one (via POW's Merge Graphs or Edit Graphs menu items), or, if the data is part of a 3-D data cube, by using an outside tool (eg, fv) to produce a graph with each 2-D slice of the cube treated as a separate image. After the graph containing all the desired images has been created and selected, select Blink Images from the Edit menu. A dialog box containing information about the current graph and controls for the blinking behavior will be displayed.

At the top of the dialog box is the name of the selected graph followed by the number of images in the graph and the image number currently in the foreground. The Prev and Next buttons immediately below this information step through the images, bringing each one to the foreground in turn. It is possible to either blink all the images in order or in a specified sequence. The Add to List button appends to this sequence list the image currently in the foreground. The sequence List entry box consists of a comma-separated list of image numbers and/or ranges (e.g., 1-3,5,8-10,14). A pair of radio buttons determines with the sequence list is used or all the images are blinked in order. Two checkbuttons control whether blinking is Looped--repeated indefinitely--or stopped after the last image is displayed, or blinked in Reverse order. A slidebar controls the Speed at which blinking occurs. All these controls can be modified while images are being blinked and will take effect immediately. To have a new list of frames take effect, though, one must reselect the List radio button.

When the controls are set to their desired values, press the Blink Images button to begin blinking. The button changes to Stop Blinking.

If the selected graph is changed while the dialog box is open, press the Reload Info button to update the dialog with the new information.

Blink Graphs...

It is not always possible to put all one's images into a single graph--images may lack a common coordinate system for automatic alignment--preventing the previous blinking method from being used. The Blink Graphs menu item allows individual graphs to be blinked. There is no "natural order" with which to blink graphs, so the user is presented with a list of all Available Graphs and must specify which graphs to blink and in which order. The Add and Insert buttons append to the end or insert at the current selection point of the Blink Order list the highlighted graphs from the Available Graphs list. A graph may appear multiple times in the Blink Order list. The Delete button removes all highlighted entries from the Blink Order list. As in the Blink Images method, a slidebar controls the speed of the blinking.

Blink begins when the Blink Graphs button is pressed. Blinking is always in the specified order (no reverse option) and will repeat indefinitely until the Stop Blinking button (same as the Blink Graphs button) is pressed.

As graphs normally don't initially overlap and will likely need to be repositioned, the graphs in the Blink Order list can be moved from within the dialog box. A compass labeled Shift & Align Graphs is present in the center of the dialog box. Clicking on the center of the compass aligns all the graphs in the list according to the top right corner of the first graph. Clicking on any of the arrows shifts the highlighted graphs 10 pixels in that direction. Shift-clicking an arrow shifts the graphs 1 pixel at a time. The graphs continue to move in these increments until the mouse button is released or the cursor leaves the compass arrow. (Note: if an individual graph is present several times in the Blink Order list, each instance of it in the highlighted selection will experience the shift.) Graphs can be repositioned with the compass while blinking.

If graphs are added to the POW canvas while the dialog box is open, press the Reload Info button to create a new list of Available Graphs.


Pages maintained by Bryan Irby
Send bug reports or feature requests via the FTOOLS help desk.


HEASARC Home | Observatories | Archive | Calibration | Software | Tools | Students/Teachers/Public

Last modified: Tuesday, 01-Aug-2006 14:44:00 EDT