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February 23, 2011

Abstract

The SAS Graphical User Interface (GUI) is intended for interactive analysis of
XMM data. It provides a graphical means of running tasks which is more convenient
than the UNIX command line.

1 Overview of main screen elements

After starting the SAS GUI you will see the components of the SAS GUI interface on screen. The inter-
face consists of a menu, a tool bar, a task browser, a log browser and a status bar. Your view may be
similar to the one shown here:
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1.1 Menu bar

On the top of the SAS GUI window you will find the menu bar. Point to a menu with the mouse and
press the left mouse button. The menu will open and you can select an item from the sub-menu by
clicking it.

The menus in the menu bar can be accessed in two ways:

Alternatively, you can us shortcut keys. If the first letter of a menu is underlined, you can access that
menu by using short cut keys.
For example, the File menu, can be accessed by pressing the key combination CTRL+F.

An item in the menu bar followed by ... gives access to a sub-menu. Some items in the menus may be
grayed out: if that is the case, such items are not accessible.
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1.1.1 File menu

The File menu gives access to:

• Preferences...

• Browse datasets...

• Print log...

• Save as script...

• Exit

1.1.2 Task menu

The Task menu gives access to:

• Revert to defaults

• Kill task...

1.1.3 Custom menu

In the current version, the Custom menu is empty

1.1.4 Style menu

The Style menu gives access to:

• Window

• Motif

• CDE

• Platinum

• Font...

1.1.5 Help menu

The Help menu gives access to:

• Tasks

• Contents

• About
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1.2 Tool bar

The main screen of the SAS GUI has a tool bar. Clicking on one of the buttons will perform a function.

Currently, the tool bar supports the following tools:

• Exploring datasets

• Printing the log history

• What’s this?

1.3 Selecting a task

The main screen of the SAS GUI has one window that lists all tasks that the SAS can perform. Such a
listing may look like:

This is what we call the task browser. The browser shows four columns:

• Name of a task,

• Main group this task belongs to,

• Last time in the history of this session, that this task is performed,

• Short description of what this task will do. A full description can be found in the documentation
of that task.
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You can navigate through browser by using your mouse or keyboard.

With your mouse, you can scroll to a specific task, using the scrollbar on the right side of this window.
If you double-click on a a specific task, you will be presented with a dialog.

Using your keyboard, you can quickly browse through the task browser. Pressing one of the Page Up,
Page Down, Home and End keys will scroll you up, down, to the beginning or to the end of the task
browser respectively.
Typing the first letters of a task name, will jump downwards to the first occurrence of such a task name.
Pressing Enter on your keyboard will launch the task dialog.

1.4 The log window

The main screen of the SAS GUI also has a window that shows what tasks are executed, and how they
are executed. The log window may look like:

If you wish, you can save the log in a script format, such that you can re-run all executed tasks in batch
form.

In the log window, you will find the changes you have made in the environment, the precise execution of
the tasks, as well as any messages produced by the tasks.

Each time a task is executed from the GUI, an equivalent command-line is written to the log. These lines
have the prefix @@, so that they may be easily identified. The File menu has an option to extract the
commands and save them as an executable script. You may wish to edit the script and replace some file
names by command-line arguments, so that the script can be run on different data.

The log also records warnings and error messages, received from the task. These are prefixed with **, so
that they are clearly visible. Other output from the task (normally written to the terminal , if the task
is executed on the command line) is logged without any prefix.

As well as being displayed in the SAS window, the log is also written to the file sas log. This file is
created in the directory from which the GUI was invoked.

The log may be printed using using the Print button in the tool bar or the File menu.
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1.5 Status bar

The status bar at the bottom of the SAS GUI gives you additional information about processes that ae
taking place in the background:

Its purpose is to give you extra information about -for example- processes that are taking place in the
background.

2 Using tasks

Once you have selected a specific SAS task, a dialog will appear. Though the dialog may be different
for every task, the all have a general layout, that may look like:

The top side of the dialog contains all parameters that are needed by this task.

Parameters may be grouped:

• Clicking on one of the tabs will show the parameters belonging to the selected tab.

• Parameters can be framed to notify the user that they logically belong to each-other.
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• Some of these frames have a check box on the top left. This check box enables or disables
all parameters in that box. If disabled, the parameters are grayed out, which means that
their values are not important to the task.

• Other frames may show a selection box. By clicking on the selection, a pull-down menu
appears where you can change the selection. Once a new selection is made, the parameters
in the box have changed.

2.1 Changing parameters

The parameter dialog presents you with the parameters that the task will use. Details about available
parameter types can be found in the param documentation.

Besides parameters that switch other parameters on or off, the GUI makes a distinction between:

• scalar parameters

A single value is expected. This value may be empty (for example, in case of a string)

• list parameters

One or more values can be entered

In general, the edit field field is preceded by a label, specifying the name of the parameter. Holding your
mouse over an edit field will generate a tool tip, explaining what input the dialog is expecting.

Some parameters can be entered in different formats. If that is the case, a pull-down menu is shown next
to the edit field of that parameter.
Other parameters may have a browse button next to the edit field. Clicking on this button will pop-up a
browser, in which you can select the value of this parameter by browsing through your file system.

You can give the focus of your keyboard to one of edit fields by clicking your mouse button in an edit

field.
Alternatively, you can use the TAB key, or the SHIFT+TAB key-combination to jump forwards and
backwards through the edit fields respectively.

2.2 Execute a task

At the bottom of the task dialog you will always find three buttons:

• Run

Starts the tasks with the selected parameters. Any changes you have made to the parameters
of this task, will be kept in memory.

• Cancel

This button will close this window. Any changes to the parameters are ignored.

• Save

This button will store your current parameters value in the $HOME/.sas.d/config directory.

• Defaults

Reverts the parameters to the values they had, when you opened this window.

file:../param/index.html
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2.3 Kill a task

You can kill a running task in the task menu.
This is useful if a long task is accidentally started with the wrong parameters or if a task appears to hang

for some reason. Killing a task may, of course, result in the output files being truncated or corrupted.

2.4 Running multiple tasks

For interactive processing, it is normal to run one task at a time. However, once a task has started, you
can open a parameter dialog to configure the parameters in preparation for running the next task. If you
press the Run button before the previous task has finished, you will be given the option of running the
task immediately or queuing it for later execution:

• Immediate execution is appropriate if the tasks make use of separate files, so that they
may be run in parallel.

• You should use queuing if the tasks form a processing chain, where each task makes use of
output from the previous task.

The next queued task is started automatically, when all currently running tasks have finished.
Tasks are logged when they are started.

When a task is started, or queued for later execution, the parameter values are saved along with the
task. Consequently, editing the parameters and queuing a second instance of a task will not affect the
parameters of a task that is already running or queued.

However, you should take the following considerations into account:

• Changing global preferences which affect a task, such as the setting of the ODF directory,
will affect all queued tasks which have not yet started.

• The kill command stops the last task started. It is only possible to kill an earlier task by
killing all later tasks. This command can not be used to remove a pending task from the
queue

• If a queued task fails, the remaining tasks in the queue are still executed.

3 Exploring datasets

The SAS GUI has a file browser. This browser can be used to explore the data sets on your file system,
or to select a parameter. Typically your explorer will look like:
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The browser not only shows your system directories and files, but also allows you to browse into data sets.

Additionally, a Cancel and an Ok button may appear at the bottom of this window, if the browser is
used in to select a parameter in the dialog of a task.

3.1 Tool bar

At the top of your browser, you will find a tool bar that is specific to the browser. It allows you to quickly
jump through your file system:

• The four left-most buttons navigate you to the pre-selected Home, ODF, CCF and Current

directories. You can change these directories in the preferences dialog.

• Next, you will find a selection toggle button. This is only useful if you are selecting
parameters for a task.
Pressing this button will show or hide a window, that lists all currently selected entries.

• The pull-down menu allows you to quickly jump to a previous visited item.

• Pressing the next button in the tool bar will jump to a higher level (for example the parent
directory).

• Finally, we have a refresh button. This button allows you to see the new files created during
the sas run.
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3.2 Tree window

In the left window you can navigate through your file system. Navigation is similar to the task browser,
except that you can also expand a tree by clicking your mouse button or using the arrow keys on your
keyboard.

As you can see, some folders are presented with an icon similar to that of the tool bar buttons. They
are the pre-selected directories. Next to your folders, this view will also show data sets as well as their
images and/or tables.

Selecting an item in this window will change the right-pane of the browser.

3.3 List window

The right window shows the contents of the item selected in the left-pane of the browser:

Navigation is similar to the task browser. Additionally, the right-button on your mouse will show a small
menu, that speaks for itself.

In this window one can view the contents of an item by either double-clicking your mouse button, pressing
Enter on your keyboard or selecting Open in the pop-up menu discussed above.
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If the browser is used for selecting parameters for a task, a single click with your mouse button will add
it to your selection box.

Note: Only items that match the parameter type can be added to your selection. The title bar of the
browser specifies what parameter type is expected.

3.4 QuickView window

Information about data set items like attributes, columns in a table as well as simple images are
displayed in this window:

3.5 Selection window

When you are selecting an item, the current selected item (or items if you have to select a list of items)
can be shown by pressing the select button in the tool-bar. This will open a window similar to:

In this window you can remove all highlighted items, or clear the complete selection.

4 Use with FTOOLS

It is possible to run many FTOOLS from within the GUI, although they are naturally not as well
integrated as native SAS tasks.

http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html
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The SAS package ftools provides parameter files and GUI layout files for a few common FTOOLS, so
that they can be run from the SAS GUI. See the documentation of that package for further details.

The following limitations should be noted:

• The user can only respond to prompts from a task by typing in the terminal window from
which the GUI was started. However, FTOOLS should not normally generate prompts since
the GUI provides values for all parameters.

• The GUI enforces the types of parameters. For example, it is not possible to enter a string
for a numeric parameter. Consequently, some numeric parameters are handled as strings
in the SAS ftools package, to allow the value INDEF to be entered. This prevents the GUI
checking the syntax or range of these parameters.

• FTOOLSwill mis-interpret the command line produce by the GUI if a string parameter is
empty. The parameter files in the SAS ftools package use a ” ” (space) or ”?” as the default
to avoid this problem.

5 Reference documentation

5.1 Setting preferences

The Preferences... item on the File menu allows you to change the behavior of tasks and to alter your
default directories:

Most items are related to the corresponding environment variables as discussed in the taskmain package.
These variables determine the default settings in this dialog.

file:../ftools/index.html
http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html
file:../ftools/index.html
http://heasarc.gsfc.nasa.gov/docs/software/ftools/ftools_menu.html
file:../ftools/index.html
file:../taskmain/index.html
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5.2 Printing the log

The log as shown in the log window can be printed, via the File menu or using the Tool bar

5.3 Saving the log

The log can be saved as a script, via the file menu or using the tool bar.

5.4 Exiting the GUI

You can exit the GUI by selecting Exit in the file menu or using the means of your favorite window
manager.

5.5 Getting back your task defaults

The task menu allows you to change all parameters of all tasks back to their defaults.

5.6 Killing a running task

The task menu allows you to stop currently running tasks.

5.7 Changing the look & feel

You can alter the look and feel of the GUI by changing the used fonts or using a different style for the
buttons, menus etc...

5.7.1 Supported styles

The GUI currently supports different look & feel of the GUI. Currently supported styles are:

• Windows

• Motif

• CDE

• Platinum

5.7.2 Supported fonts

The supported fonts depend on your system. A dialog will appear with all possible fonts.
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5.8 Tasks messages

Messages of running tasks appear in the log window.
Additionally, warning and error messages may pop up a small window to alert the user:

Warning dialogs include a check-box, which allows subsequent occurrences of the same warning to be
ignored, so that no further user interaction is needed. However, all occurrences are still written to the
log. The warning is re-enabled next time the task is run.

Note that warnings can also be suppressed via command line switches as discussed in the taskmain

package.

5.9 Help

The SAS GUI provides 3 levels of help:

• Yellow tool tips pop up when the cursor is placed and held over an item.

• The main window has a What’s this button, in the tool bar; select the help tool and click
it on an item to obtain more detailed help.

• The help menu provides access to the on-line documentation of the GUI as well as how to
use a specific task.

The on-line documentation requires that Netscape is already running before selecting Help.
The help menu passes the URL of the requested documentation to Netscape.
If you use a different web browser, simply invoke the browser on README.html in the
SAS DIR directory.

file:../taskmain/index.html
http://www.netscape.com
http://www.netscape.com
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5.9.1 Reference documentation of all tasks

Access to documentation of all available packages in this release.

5.9.2 Current documentation

What you are seeing now.

5.9.3 About the SAS

Shows a small window with information about this release.

5.9.4 What’s this button

Clicking on this button will change the appearance of the cursor. By clicking your mouse again, it will
give you a description of the window the cursor was pointing at.

5.9.5 Tooltips

Tool tips appear when you keep your mouse over a button or a input field.
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