Due to the plugin's growing age and its instability, we have ceased development with it and are no longer supporting its use. Its most recent release is still available below, but we cannot provide assistance should it not work for you as is.

Get the LHEATcl Plugin!

NEW! Version 2.0.1 is now available. Unix users: If you have installed the previous version, you may need to remove liblheatclp20.so from your .netscape/plugins directory before installing this one. This is powered by the LHEA plugin. If the indicator below is not green, you need to get the plugin.

Are you ready to view these pages ? <- Should be green if you have the latest LHEA Plugin version!

Read the API documentation for what's different from the Scriptics version of the plugin and how to use the extra features.

Installing the LHEATcl Plugin

To install, simply download the appropriate file for your given platform (by clicking on it). For the unix flavors, just type:
  1. gzip -dc tclplug20-platform.tar.gz | tar xvf -
  2. cd tclplug20-platform
  3. ./install.sh
For Windows/Windows NT and Macintosh, just grab the self-extracting files below and execute them.

All Plug-in flavors

NOTE: We have dropped support for the plugin and cannot provide assistance should you decide to install the plugin.
  • Alpha/OSF 4.0
  • Solaris 2.6 (aka SunOS 5.6) for Sparc
  • SunOS 4.1 for Sparc
  • SGI/IRIX 6.5 built with "o32" object format, so it might work on 5.x machines, we don't have one to test it on. Probably won't work on 64 bit machines, get in touch with us if you have one and we'll see what we can do for you.
  • Linux for x86 glibc2.0 (e.g. Redhat 5.x).
  • Linux for x86 glibc2.1 (e.g. Redhat 6.x).
  • Linux for PPC/Mac is not working yet.
  • Windows 95/98/NT This file will install the plugin for Netscape 3 or 4 and IE 3, 4, or 5.
  • Macintosh The lheaplugin for Macintosh, supporting Any PowerPC Macintosh with 64 Meg of memory and MacOS 7.5 and later. Netscape Navigator or Communicator v4.x. (Internet Explorer is not supported.)

    Retired plugin versions

    These are binaries for the 2.0 version of the plugin on platforms we are no longer able to support. They might be of some use.
    1. Linux for x86 libc (earlier flavors of Linux) (or FreeBSD with the linux compatibility mode)
    2. SGI/IRIX 5.3 The current IRIX 6.5 binary will probably work, we suggest you try it first, anyway.


    Here's the Source file. Building it yourself is easier than the last release but is still only recommended for "advanced" users or if the binaries don't work for some reason. See the README file in the top level of the source distribution for notes on build issues for specific systems.

    If you have any problems or need a binary for a platform that isn't here, just email us at wasabi@athena.gsfc.nasa.gov